CVE-2016-4359

Properties

Published:
07.06.2016
Updated:
21.06.2016
Patch available:
Severity:
High
CVSS vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Product:
hp: performance_center
hp: performance_center
hp: performance_center
hp: performance_center
hp: performance_center

Vulnerability description

Stack-based buffer overflow in mchan.dll in the agent in HPE LoadRunner 11.52 through patch 3, 12.00 through patch 1, 12.01 through patch 3, 12.02 through patch 2, and 12.50 through patch 3 and Performance Center 11.52 through patch 3, 12.00 through patch 1, 12.01 through patch 3, 12.20 through patch 2, and 12.50 through patch 1 allows remote attackers to execute arbitrary code via a long -server_name value, aka ZDI-CAN-3516.

References:

CONFIRM: https://h20566.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c05157423
MISC: http://www.zerodayinitiative.com/advisories/ZDI-16-363
MISC: http://www.tenable.com/security/research/tra-2016-16
SECTRACK: http://www.securitytracker.com/id/1036006