CVE-2016-3703

Properties

Published:
07.06.2016
Updated:
10.06.2016
Patch available:
Severity:
Low
  • CVSS vector:
    (AV:N/AC:M/Au:S/C:P/I:N/A:N)
    Product:
    redhat: openshift
    redhat: openshift

    Vulnerability description

    Red Hat OpenShift Enterprise 3.2 and 3.1 do not properly validate the origin of a request when anonymous access is granted to a service/proxy or pod/proxy API for a specific pod, which allows remote attackers to access API credentials in the web browser localStorage via an access_token in the query parameter.

    References:

    REDHAT: https://access.redhat.com/errata/RHSA-2016:1095
    REDHAT: https://access.redhat.com/errata/RHSA-2016:1094