CVE-2009-0927

Properties

Published:
18.03.2009
Updated:
28.04.2009
Patch available:
Severity:
High
CVSS vector:
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Product:
adobe: reader
adobe: reader
adobe: reader
adobe: reader
adobe: reader
adobe: reader
adobe: reader
adobe: reader
adobe: reader
adobe: reader
adobe: reader
adobe: acrobat
adobe: acrobat
adobe: acrobat

Vulnerability description

Stack-based buffer overflow in Adobe Reader and Adobe Acrobat 9 before 9.1, 8 before 8.1.3 , and 7 before 7.1.1 allows remote attackers to execute arbitrary code via a crafted argument to the getIcon method of a Collab object, a different vulnerability than CVE-2009-0658.

References:

CONFIRM: http://www.adobe.com/support/security/bulletins/apsb09-04.html
XF: http://xforce.iss.net/xforce/xfdb/49312
MISC: http://www.zerodayinitiative.com/advisories/ZDI-09-014
VUPEN: http://www.vupen.com/english/advisories/2009/1019
VUPEN: http://www.vupen.com/english/advisories/2009/0770
SECTRACK: http://www.securitytracker.com/id?1021861
BID: http://www.securityfocus.com/bid/34169
BUGTRAQ: http://www.securityfocus.com/archive/1/archive/1/502116/100/0/threaded
SUNALERT: http://sunsolve.sun.com/search/document.do?assetkey=1-66-256788-1
GENTOO: http://security.gentoo.org/glsa/glsa-200904-17.xml
SECUNIA: http://secunia.com/advisories/34790
SECUNIA: http://secunia.com/advisories/34706
SECUNIA: http://secunia.com/advisories/34490
SUSE: http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00010.html
SUSE: http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00005.html