CVE-2007-1087

Properties

Published:
22.02.2007
Updated:
26.02.2007
Patch available:
Severity:
High
CVSS vector:
(AV:L/AC:L/Au:NR/C:C/I:C/A:C/B:N)
Product:
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database
IBM: DB2 Universal Database

Vulnerability description

IBM DB2 8.x before 8.1 FixPak 15 and 9.1 before Fix Pack 2 does not properly terminate certain input strings, which allows local users to execute arbitrary code via unspecified environment variables that trigger a heap-based buffer overflow.

References:

IDEFENSE: http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=481
AIXAPAR: http://www-1.ibm.com/support/docview.wss?uid=swg21255747
BID: http://www.securityfocus.com/bid/22677