CVE-2006-2402

Properties

Published:
14.05.2006
Updated:
22.10.2018
Patch available:
Severity:
Medium
CVSS vector:
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Product:
outgun: outgun
outgun: outgun
outgun: outgun

Vulnerability description

Buffer overflow in the changeRegistration function in servernet.cpp for Outgun 1.0.3 bot 2 and earlier allows remote attackers to change the registration information of other players via a long string.

References:

MISC: http://aluigi.altervista.org/adv/outgunx-adv.txt
SREASON: http://securityreason.com/securityalert/898
BUGTRAQ: http://www.securityfocus.com/archive/1/433932/100/0/threaded
BID: http://www.securityfocus.com/bid/17985
VUPEN: http://www.vupen.com/english/advisories/2006/1796
XF: https://exchange.xforce.ibmcloud.com/vulnerabilities/26513