CVE-2016-3706

Properties

Published:
09.06.2016
Updated:
10.06.2016
Patch available:
Severity:
Medium
CVSS vector:
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Product:
novell: opensuse

Vulnerability description

Stack-based buffer overflow in the getaddrinfo function in sysdeps/posix/getaddrinfo.c in the GNU C Library (aka glibc or libc6) allows remote attackers to cause a denial of service (crash) via vectors involving hostent conversion. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-4458.

References:

CONFIRM: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=4ab2ab03d4351914ee53248dc5aef4a8c88ff8b9
CONFIRM: https://sourceware.org/bugzilla/show_bug.cgi?id=20010
SUSE: http://lists.opensuse.org/opensuse-updates/2016-06/msg00030.html