CVE-2008-1244

Properties

Published:
09.03.2008
Updated:
31.08.2009
Patch available:
Severity:
High
CVSS vector:
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Product:
belkin: f5d7230-4

Vulnerability description

cgi-bin/setup_dns.exe on the Belkin F5D7230-4 router with firmware 9.01.10 does not require authentication, which allows remote attackers to perform administrative actions, as demonstrated by changing a DNS server via the dns1_1, dns1_2, dns1_3, and dns1_4 parameters.  NOTE: it was later reported that F5D7632-4V6 with firmware 6.01.08 is also affected.

References:

MISC: https://bugzilla.mozilla.org/show_bug.cgi?id=371598
BUGTRAQ: http://www.securityfocus.com/archive/1/archive/1/489009/100/0/threaded
MISC: http://www.gnucitizen.org/projects/router-hacking-challenge/
XF: http://xforce.iss.net/xforce/xfdb/41124
BID: http://www.securityfocus.com/bid/28319
SECUNIA: http://secunia.com/advisories/29345