CVE-2007-5805

Properties

Published:
04.11.2007
Updated:
07.11.2007
Patch available:
Severity:
Medium
CVSS vector:
(AV:L/AC:M/Au:N/C:C/I:C/A:C)
Product:
IBM: AIX
IBM: AIX

Vulnerability description

cfgcon in IBM AIX 5.2 and 5.3 does not properly validate the argument to the"-p"option to swcons, which allows local users in the system group to create an arbitrary file, and enable world writability of this file, via a symlink attack involving use of the file's name as the argument.  NOTE: this issue is due to an incomplete fix for CVE-2007-5804.

References:

IDEFENSE: http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=611
ftp://aix.software.ibm.com/aix/efixes/security/cfgcon_ifix.tar: ftp://aix.software.ibm.com/aix/efixes/security/cfgcon_ifix.tar
http://www14.software.ibm.com/webapp/set2/subscriptions/ijhifoeblist?mode=7&heading=AIX53&path=%2F200710%2FSECURITY%2F20071030%2Fdatafile100405: http://www14.software.ibm.com/webapp/set2/subscriptions/ijhifoeblist?mode=7&heading=AIX53&path=%2F200710%2FSECURITY%2F20071030%2Fdatafile100405
AIXAPAR: http://www-1.ibm.com/support/docview.wss?uid=isg1IZ03055
AIXAPAR: http://www-1.ibm.com/support/docview.wss?uid=isg1IZ03061
BID: http://www.securityfocus.com/bid/26258
XF: http://xforce.iss.net/xforce/xfdb/38154