CVE-2007-4447

Properties

Published:
19.08.2007
Updated:
23.08.2007
Patch available:
Severity:
High
CVSS vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Product:
Toribash: Toribash

Vulnerability description

Multiple buffer overflows in the client in Toribash 2.71 and earlier allow remote attackers to (1) execute arbitrary code via a long game command in a replay (.rpl) file and (2) cause a denial of service (application crash) via a long SAY command that omits a required LF character; and allow remote Toribash servers to execute arbitrary code via (3) a long game command and (4) a long SAY command that omits a required LF character.

References:

BUGTRAQ: http://www.securityfocus.com/archive/1/archive/1/477025/100/0/threaded
http://aluigi.org/poc/toribashish.zip: http://aluigi.org/poc/toribashish.zip
BID: http://www.securityfocus.com/bid/25359
SECUNIA: http://secunia.com/advisories/26507