CVE-2007-2872

Properties

Published:
03.06.2007
Updated:
29.12.2007
Patch available:
Severity:
Medium
CVSS vector:
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Product:
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP
PHP: PHP

Vulnerability description

Multiple integer overflows in the chunk_split function in PHP 5 before 5.2.3 allow remote attackers to cause a denial of service (crash) or execute arbitrary code via the (1) chunks, (2) srclen, and (3) chunklen arguments.

References:

http://www.php.net/releases/5_2_3.php: http://www.php.net/releases/5_2_3.php
BUGTRAQ: http://www.securityfocus.com/archive/1/archive/1/470244/100/0/threaded
http://www.sec-consult.com/291.html: http://www.sec-consult.com/291.html
https://issues.rpath.com/browse/RPL-1702: https://issues.rpath.com/browse/RPL-1702
https://issues.rpath.com/browse/RPL-1693: https://issues.rpath.com/browse/RPL-1693
http://support.avaya.com/elmodocs2/security/ASA-2007-449.htm: http://support.avaya.com/elmodocs2/security/ASA-2007-449.htm
https://launchpad.net/bugs/173043: https://launchpad.net/bugs/173043
FEDORA: https://www.redhat.com/archives/fedora-package-announce/2007-September/msg00354.html
FEDORA: https://www.redhat.com/archives/fedora-package-announce/2007-September/msg00397.html
GENTOO: http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml
HP: http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01178795
MANDRIVA: http://www.mandriva.com/security/advisories?name=MDKSA-2007:187
OPENPKG: http://www.openpkg.com/security/advisories/OpenPKG-SA-2007.020.html
REDHAT: http://www.redhat.com/support/errata/RHSA-2007-0890.html
REDHAT: http://rhn.redhat.com/errata/RHSA-2007-0889.html
REDHAT: http://www.redhat.com/support/errata/RHSA-2007-0888.html
REDHAT: http://www.redhat.com/support/errata/RHSA-2007-0891.html
SLACKWARE: http://slackware.com/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.482863
SUSE: http://lists.opensuse.org/opensuse-security-announce/2007-07/msg00006.html
TRUSTIX: http://www.trustix.org/errata/2007/0023/
UBUNTU: http://www.ubuntulinux.org/support/documentation/usn/usn-549-1
UBUNTU: http://www.ubuntu.com/usn/usn-549-2
BID: http://www.securityfocus.com/bid/24261
FRSIRT: http://www.frsirt.com/english/advisories/2007/2061
FRSIRT: http://www.frsirt.com/english/advisories/2007/3386
SECTRACK: http://www.securitytracker.com/id?1018186
SECUNIA: http://secunia.com/advisories/25535
SECUNIA: http://secunia.com/advisories/25456
SECUNIA: http://secunia.com/advisories/26048
SECUNIA: http://secunia.com/advisories/26231
SECUNIA: http://secunia.com/advisories/26838
SECUNIA: http://secunia.com/advisories/26930
SECUNIA: http://secunia.com/advisories/26871
SECUNIA: http://secunia.com/advisories/26895
SECUNIA: http://secunia.com/advisories/26967
SECUNIA: http://secunia.com/advisories/27037
SECUNIA: http://secunia.com/advisories/27110
SECUNIA: http://secunia.com/advisories/27351
SECUNIA: http://secunia.com/advisories/27377
SECUNIA: http://secunia.com/advisories/27545
SECUNIA: http://secunia.com/advisories/27102
SECUNIA: http://secunia.com/advisories/27864