CVE-2006-6331

Properties

Published:
05.12.2006
Updated:
26.02.2008
Patch available:
Severity:
Medium
CVSS vector:
(AV:N/AC:M/Au:S/C:P/I:P/A:P)
Product:
TorrentFlux: TorrentFlux

Vulnerability description

metaInfo.php in TorrentFlux 2.2, when $cfg["enable_file_priority"] is false, allows remote attackers to execute arbitrary commands via shell metacharacters (backticks) in the torrent parameter to (1) details.php and (2) startpop.php.

References:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=%23400582: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=%23400582
http://bugs.debian.org/cgi-bin/bugreport.cgi/11_missed_security_fixes.dpatch?bug=400582;msg=71;att=1: http://bugs.debian.org/cgi-bin/bugreport.cgi/11_missed_security_fixes.dpatch?bug=400582;msg=71;att=1
SECUNIA: http://secunia.com/advisories/23270