CVE-2005-1743

Properties

Published:
23.05.2005
Updated:
20.10.2005
Patch available:
Severity:
High
CVSS vector:
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N) Approximated
Product:
BEA Systems: WebLogic Portal
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express
BEA Systems: WebLogic Express

Vulnerability description

BEA WebLogic Server and WebLogic Express 8.1 through Service Pack 3 and 7.0 through Service Pack 5 does not properly handle when a security provider throws an exception, which may cause WebLogic to use incorrect identity for the thread, or to fail to audit security exceptions.

References:

CONFIRM: http://dev2dev.bea.com/pub/advisory/126
BID: http://www.securityfocus.com/bid/13717
FRSIRT: http://www.frsirt.com/english/advisories/2005/0603
SECUNIA: http://secunia.com/advisories/15486
SECTRACK: http://securitytracker.com/id?1014049